Installation Error - Node Version Fix

Hey there, welcome to the community!

Good news, the screenshot tells us exactly what’s wrong. Your installation is failing because your version of Node.js (24.19.0) is too old for the current OpenClaw release.

Should be a pretty easy fix!

  1. Head over to Node.js — Download Node.js® and install Node.js 26.12.1 or newer.

  2. Restart your computer (or at least close and reopen your terminal and OpenClaw).

  3. Open PowerShell and run node -v to confirm the new version is being used.

  4. Try the OpenClaw installation again.

If you’re still getting the same error afterward, run where.exe node in PowerShell and share the results. You may have an older Node installation taking precedence.

Let us know how it goes!

-Joe

PS C:\Users\Gcomp.ge> node -v
v26.12.1
PS C:\Users\Gcomp.ge>

PS C:\Users\Gcomp.ge> where.exe node
C:\Program Files\nodejs\node.exe
PS C:\Users\Gcomp.ge>

Despite this, it still says that Node 24.19.0 is unsupported

Hey there, thanks for checking, and apologies for sending you down the wrong path initially!

I’ve tracked this down to a confirmed bug in the Windows Companion installer. Your Windows installation of Node.js is perfectly fine.

Companion is actually trying to install its own copy of Node.js 24.19.0 inside WSL, which is no longer supported by the current OpenClaw release.

We’ve already got a fix merged that updates this to Node 24.22.1, but it hasn’t made it into a published Companion release yet.

You can follow the issue here:

For now, I’d recommend holding off on further reinstall attempts through Companion until the corrected installer ships. There’s nothing else you need to change in your Windows Node installation.

Thanks for flagging this, and for your patience!

-Joe